• 欢迎来到小爱博客,一个分享互联网IT技术的网站,喜欢就收藏吧!

python报错 RequestsDependencyWarning: urllib3 (1.24.3) or chardet (2.2.1) doesn’t match a supported version

python 小爱 3个月前 (08-08) 56次浏览 已收录 0个评论 扫描二维码

RequestsDependencyWarning: urllib3 (1.24.3) or chardet (2.2.1) doesn’t match a supported version

问题复现:
新安装docker-compose后,每次运行docker-compose都会报错,信息如下:

<code class="has-numbering"># docker-comopse -v

/usr/lib/python2.7/site-packages/requests/__init__.py:91: RequestsDependencyWarning: urllib3 (1.24.3) or chardet (2.2.1) doesn't match a supported version!
  RequestsDependencyWarning)
</code>

原因:python库中urllib3 (1.24.3) or chardet (2.2.1) 的版本不兼容

解决如下:

<code class="has-numbering"># pip uninstall urllib3
# pip uninstall chardet
# pip install requests</code>

喜欢 (0)
【你的支持, 我的动力】
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址